Wednesday, June 2, 2010

How to install Skype in Fedora 13 x64

  1. su
  2. curl http://ftp-stud.hs-esslingen.de/pub/fedora/linux/updates/13/i386/nss-softokn-freebl-3.12.4-19.fc13.i686.rpm -o nss-softokn-freebl-3.12.4-19.fc13.i686.rpm
  3. yum install nss-softokn-freebl-3.12.4-19.fc13.i686.rpm
  4. yum install alsa-lib.i686 dbus-libs.i686 e2fsprogs-libs.i686 expat.i686 fontconfig.i686 freetype.i686 glib2.i686 glibc.i686 keyutils-libs.i686 krb5-libs.i686 libcap.i686 libgcc.i686 libICE.i686 libpng.i686 libselinux.i686 libSM.i686 libstdc++.i686 libX11.i686 libXau.i686 libxcb.i686 libXcursor.i686 libXdmcp.i686 libXext.i686 libXfixes.i686 libXi.i686 libXinerama.i686 libXrandr.i686 libXrender.i686 libXScrnSaver.i686 libXv.i686 openssl.i686 qt.i686 qt-x11.i686 zlib.i68
  5. yum install libv4l.i686

  6. Now install Skype:
Create repo file:
gedit /etc/yum.repos.d/skype.repo

Put into skype.repo:
[skype]
name=Skype Repository
baseurl=http://download.skype.com/linux/repos/fedora/updates/i586/
gpgkey=http://gd.tuwien.ac.at/infosys/phone/skype/rpm-public-key.asc
gpgcheck=0

Install skype:
yum install skype
Start skype using the command (this is what made video work):
env LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
Source

9 comments:

Gustavo said...

You may have forgot the following:

curl http://ftp-stud.hs-esslingen.de/pub/fedora/linux/updates/13/i386/nss-softokn-3.12.4-19.fc13.i686.rpm -o nss-softokn-3.12.4-19.fc13.i686.rpm
yum install nss-softokn-3.12.4-19.fc13.i686.rpm

Emon said...

cool .. yeah forgot about that. Thanks!

Hey how did you get microphone working in Skype?

Haji-W said...

Thank you very much! very usefull

Mohammad Nadim said...

Hello. I'm a 2-week old newbie to Linux (Fedora 13 64-bit). Didn't find the package at step 2. So I did everything except steps 2 and 3. Skype installed correctly. It says "Skype 2.1 (Beta) for Linux"

My mic works perfectly and I can do video chat also :-)

I got this error though (first time):

X Error, request 42, minor 0, error code 8 BadMatch (invalid parameter attributes)

(:11650): Gtk-WARNING **: Unable to locate theme engine in module_path: "qtcurve",

(:11650): Gtk-WARNING **: Unable to locate theme engine in module_path: "qtcurve",


Didn't get it after that.

Thanks for your help :-)

robh said...

I tried all the above and when i tried to reinstall Skype i got the following "File contains no section headers.
file: file://///etc/yum.repos.d/skype.repo, line: 1
'Put into skype.repo:\n'"

I also tried to edit the repos.d file under etc/yum, but it will not allow it please help. Prior to this I had voice on skype but no video, now i have nothing.

nadim said...

[My machine got a problem; so reinstalled Fedora 13]

Then when installing skype, after doing

yum install skype

i get:

Loaded plugins: fastestmirror, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: mirror.cse.iitk.ac.in
* rpmfusion-free: mirror.cse.iitk.ac.in
* rpmfusion-free-updates: mirror.cse.iitk.ac.in
* rpmfusion-nonfree: mirror.cse.iitk.ac.in
* rpmfusion-nonfree-updates: mirror.cse.iitk.ac.in
* updates: mirror.cse.iitk.ac.in
Setting up Install Process
No package skype available.
Error: Nothing to do

Had to download a local copy of Skype from their website and did a localinstall:

yum --nogpgcheck localinstall ./skype-2.1.0.81-fc10.i586.rpm

Installed correctly with voice + webcam enabled ;)nadimattari');

nadim said...

@robh

I am new to linux (one-month old user or so). You cannot edit the file etc/yum.repos.d/skype.repo because probably you have not tried to do so as root. Enter the command "su" in terminal (will ask for the password); then try to edit the file. hope it helps...

nadim

ShreeRam said...

hi,
my name is nitinkumar i have occurred the problem i am updated fedora Linux operating system but i have no idea about this updated fedora 13 plz..........
suggested me
good by thanks

Paul Cortens said...

This worked for me on Fedora 15 (beta). But a couple steps were not necessary.

1) I did not need to download and install nss-softokn-freebl. I already had a similar package installed via yum.

2) I did not need the special command (env LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype) to start Skype. I am able to start skype with just "skype" or by pressing the icon in the applications menu. Audio and video works.

Finally, I wanted to note that this doesn't seem to install the latest version. I got version 2.1, where as the Skype website has a 2.2 rpm available for download.

FizzBuzz in different languages

Java: import java.util.TreeMap ; public class Main { public static void main (String[] args) { System. out .println( &...